Author Topic: A15 SGC layout  (Read 9369 times)

nevyn

  • Newbie
  • *
  • Posts: 42
A15 SGC layout
« on: 2011-03-17 12:39:00 »
whew!

after a frantic few days, i have finally gotten my pet project up and running!

it's an updated (and vastly improved) version of my old layout, this time complete with:

4 x tabs -Main (system overview), CPU, GPU and Net usage
making use of the left and right arrows on the G19
new mail icon
animated decor on the 'main' background

you'll need:
speedfan
coretemp
GPU-Z; and
FRAPS

many, many thanks to Triscopic! without that LH_Cursor layout you posted, this would have been well-nigh impossible for me to get to grips with.
as it was, i nearly tore my hair out a few times, until i got the hang of it. you, mate, are a legend!

as usual, comments, suggested improvements etc are very welcome!  ;D

« Last Edit: 2011-03-17 12:48:48 by nevyn »

Ender91

  • Sr. Member
  • ****
  • Posts: 336
  • Alpha & Omega
Re: A15 SGC layout
« Reply #1 on: 2011-03-17 14:13:19 »
I've just tested it... looks cool, but the web plugin doesn't seem to work (for me at least..).

EDIT: It's because the html points to files according to a path that only works on your computer, I should look for files in the same folder....

For exemple see those lines:
ultimateshow[0]=['file:///C:/Users/Nevyn/Documents/LCDHost/layouts/sgc2/BG main decor/1.png']
ultimateshow[1]=['file:///C:/Users/Nevyn/Documents/LCDHost/layouts/sgc2/BG main decor/2.png']
« Last Edit: 2011-03-17 14:19:25 by Ender91 »

nevyn

  • Newbie
  • *
  • Posts: 42
Re: A15 SGC layout
« Reply #2 on: 2011-03-18 02:05:59 »
yeah, i tried repeatedly to get the html files to recognise a shorter form of file addressing for the pics, but it just wouldnt work.

all the images etc are stored in the appropriate sub-folders in the .zip file.

a 'replace all' should be all that is needed to fix it, but i wish it didnt have to be that way.

any suggestions on how to work-around it?

Triscopic

  • Hero Member
  • *****
  • Posts: 729
  • ˙ǝıl ɐ sı ǝʞɐɔ ǝɥʇ
Re: A15 SGC layout
« Reply #3 on: 2011-03-28 11:22:18 »
May have one for you in A16 - the WebKitHTML object should allow you use a place holder for the layout folder path \layout_path. Not currently available for the WebKitURL class but I would like to look at getting this to work too before A16 comes out.

Cruise

  • Newbie
  • *
  • Posts: 9
Re: A15 SGC layout
« Reply #4 on: 2011-05-18 18:07:09 »
Loving it, just cant get it to work..

Changed the html's to the paths of my own like so :
ultimateshow[0]=['file:///C:/Users/Cruise/Documents/LCDHost/layouts/sgc/ball/ball1.png']

Also noticed that my slash ( / ) is the other way around when i copy my target above in my pc, like this :
C:\Users\Cruise\Documents\LCDHost\layouts\sgc\ball

Still shows me a white box with parcing text in it on the place where the annimation's gtta be.
Any help would be sweet..



Thx
« Last Edit: 2011-05-18 18:25:05 by Cruise »

nevyn

  • Newbie
  • *
  • Posts: 42
Re: A15 SGC layout
« Reply #5 on: 2011-05-19 00:48:41 »
Sadly, you are not alone there, mate.

Something in the latest release has stuffed  the webkit. bits.

It is being looked into, but in the mean time, none of the animatd dicons etc work. :-(

Cruise

  • Newbie
  • *
  • Posts: 9
Re: A15 SGC layout
« Reply #6 on: 2011-05-19 14:34:23 »
Ah damn...

Changed it a bit then, removed the webkit stuff and just used a static image of the ball.
Not bad but would love to see it with the animated stuff on.



Keep up the good work m8, sweetest layout in here for sure!

SirReal

  • Administrator
  • Hero Member
  • *****
  • Posts: 735
    • linkdata.se
Re: A15 SGC layout
« Reply #7 on: 2011-05-19 14:57:15 »
You might try the static LH_Text, which supports a subset of HTML and CSS.

Cruise

  • Newbie
  • *
  • Posts: 9
Re: A15 SGC layout
« Reply #8 on: 2011-05-20 14:21:53 »
Weird, today rebooted my pc and there were the animations.. working and all.
No idea what happened, didnt do a thing lol..
Saved it and wll be keeping a backup  :P

Thanks again, best applet/layout out there.

Something that would make it even better would be a music page? call it MP3 or something?
Just a suggestion, would do it myself but im afraid to mess it up, dont know a damn about how to add the controll for arrows on the keyboard and to make the screen with the pretty blue :P
« Last Edit: 2011-05-20 14:23:39 by Cruise »

nevyn

  • Newbie
  • *
  • Posts: 42
Re: A15 SGC layout
« Reply #9 on: 2011-05-20 14:27:35 »
I wanted to make a flash 'offworld Activation' when a new mail was received, and all kinds of bells and whistles, but all the animation made the layout lag to buggery.

I want to, at some point, add a 'comms' tab, for music, and teamspeak3 etc, but haven't had the time...

Cruise

  • Newbie
  • *
  • Posts: 9
Re: A15 SGC layout
« Reply #10 on: 2011-05-20 14:38:14 »
Hah, that would be sweet indeed, no lag here thoh, all is perfectly running.

A comms tab, that could work to :D
When you dont have time you dont have time, bookmarked this thread so wll check in now and then.
I wnna keep up to date eh hah, very nice work again. Lovin it.

nevyn

  • Newbie
  • *
  • Posts: 42
Re: A15 SGC layout
« Reply #11 on: 2011-05-21 04:58:29 »
i have no idea how yours managed to work again :-P

upon reboot, the nasty white blocks have gone from mine, but the animations still aren't working.

ah well, i guess i'll keep tinkering.

Cruise

  • Newbie
  • *
  • Posts: 9
Re: A15 SGC layout
« Reply #12 on: 2011-05-21 12:13:19 »
if there is anything i cn do, dont be afraid to give a yell.

Been looking into the working annimations all of a sudden thing and im rlly baffled, not a thing changed and working :P

nevyn

  • Newbie
  • *
  • Posts: 42
Re: A15 SGC layout
« Reply #13 on: 2011-05-26 08:08:32 »
well, mine worked for no apparent reason after a reboot as well  ;D

Triscopic also fixed the file paths for me, sot he layout should now work for others no matter where they extract it to, without having to rename file paths (thanks again!)

i have attached a copy of the most recent version, which is all working for A16.

Triscopic

  • Hero Member
  • *****
  • Posts: 729
  • ˙ǝıl ɐ sı ǝʞɐɔ ǝɥʇ
Re: A15 SGC layout
« Reply #14 on: 2011-06-03 09:32:57 »
Triscopic also fixed the file paths for me, sot he layout should now work for others no matter where they extract it to, without having to rename file paths (thanks again!)

No problem.

Oh, and... Crivens!

 

anything